[Linux] Чехарда с libssl

Mini web-сервер для печати чеков на фискальных регистраторах из мобильных приложений через HTTP запрос JSON.

[Linux] Чехарда с libssl

Сообщение Вторник 25 дек 2018, 04:51

Что происходит с требуемой версией libssl?

Сначала нужно было ставить 1.0.0. Ладно.

Версии 2.1.24.16 нужен уже libssl 1.0.2. Ладно. Поменял 16.04 на Stretch, проблема решилась.

Проходит неделя, и вот для 2.1.25.14 опять нужен 1.0.0. Но в репозиториях Stretch такого уже нет. Опять менять дистрибутив?
Аватара пользователя
Вторник

 
Сообщений: 157
Зарегистрирован: 16 май 2017, 08:36

Re: [Linux] Чехарда с libssl

Сообщение Audim 25 дек 2018, 18:47

Да, в Deb системах разным дистрибутивам нужна разные версии
Причем последней убунте нужна 1.0.0., поэтому и поменял назад....

Как сделать Deb пакет чтоб он подходил разным дистрибутивам пока не смог....
Audim
Администратор
 
Сообщений: 1363
Зарегистрирован: 17 мар 2015, 18:36

Re: [Linux] Чехарда с libssl

Сообщение Вторник 25 дек 2018, 22:21

Audim писал(а):Как сделать Deb пакет чтоб он подходил разным дистрибутивам пока не смог....


Я не пробовал, но кажется это оно.
Аватара пользователя
Вторник

 
Сообщений: 157
Зарегистрирован: 16 май 2017, 08:36

Re: [Linux] Чехарда с libssl

Сообщение Вторник 29 дек 2018, 14:29

В 2.1.25.15 порядок. Спасибо.
Аватара пользователя
Вторник

 
Сообщений: 157
Зарегистрирован: 16 май 2017, 08:36


Вернуться в Форум поддержки KKM web-сервер


Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 2