Пингвиньи радости

Mini web-сервер для печати чеков на фискальных регистраторах из мобильных приложений через HTTP запрос JSON.
Audim
Администратор
Сообщения: 1788
Зарегистрирован: 17 мар 2015, 18:36

Re: Пингвиньи радости

Сообщение Audim » 19 дек 2019, 17:24

Попробую указать ARMHF... правда не на чем проверить....

MF4
Сообщения: 5
Зарегистрирован: 19 дек 2019, 15:05

Re: Пингвиньи радости

Сообщение MF4 » 19 дек 2019, 18:05

Audim писал(а):
19 дек 2019, 17:24
Попробую указать ARMHF... правда не на чем проверить....
Как-то можно будет узнать, когда укажите ARMHF? Нужно будет заново перекачать пакет KkmServerArm.deb?

На сайте Raspberry есть образ для десктопа, его можно на виртуалке поднять, может на нем вы сможете проверить?

MF4
Сообщения: 5
Зарегистрирован: 19 дек 2019, 15:05

Re: Пингвиньи радости

Сообщение MF4 » 20 дек 2019, 05:26

Попробовал дальше поставить KkmServerArm на armhf. При установке выдало следующее:

Код: Выделить всё

pi@raspberrypi:~ $ sudo dpkg -i KkmServerArm.deb
Выбор ранее не выбранного пакета kkmserver:armel.
(Чтение базы данных … на данный момент установлено 155760 файлов и каталогов.)
Подготовка к распаковке KkmServerArm.deb …
Распаковывается kkmserver:armel (2.1.31.18) …
dpkg: зависимости пакетов не позволяют настроить пакет kkmserver:armel:
 kkmserver:armel зависит от liblttng-ust0.
 kkmserver:armel зависит от libcurl3 | libcurl4.
 kkmserver:armel зависит от libssl1.0.0 | libssl1.0.2.
 kkmserver:armel зависит от libkrb5-3.
 kkmserver:armel зависит от zlib1g.
 kkmserver:armel зависит от libc6-dev.
 kkmserver:armel зависит от libgdiplus.

dpkg: ошибка при обработке пакета kkmserver:armel (--install):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 kkmserver:armel
Далее после выполнения - sudo bash /opt/kkmserver/Settings/RegisterLinux.sh

Код: Выделить всё

pi@raspberrypi:~ $ sudo bash /opt/kkmserver/Settings/RegisterLinux.sh
cat: /etc/lsb-release: Нет такого файла или каталога
cat: /etc/lsb-release: Нет такого файла или каталога
cat: /etc/lsb-release: Нет такого файла или каталога
OS: linux
DIST:
DistroBasedOn: debian
REV:
MACH: armv7l
Добавление пользователя pi в группу dialout
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 kkmserver:armel : Зависит: liblttng-ust0:armel но он не может быть установлен
                   Зависит: libcurl3:armel но он не может быть установлен или
                                   libcurl4:armel но он не может быть установлен
                   Зависит: libssl1.0.0:armel но он не может быть установлен или
                                   libssl1.0.2:armel но он не может быть установлен
                   Зависит: libkrb5-3:armel но он не может быть установлен
                   Зависит: zlib1g:armel но он не может быть установлен
                   Зависит: libc6-dev:armel но он не может быть установлен
                   Зависит: libgdiplus:armel но он не может быть установлен
                   Рекомендует: libicu60:armel но он не может быть установлен или
                                           libicu57:armel но он не может быть установлен или
                                           libicu55:armel но он не может быть установлен или
                                           libicu52:armel но он не может быть установлен
 liblttng-ust0 : Зависит: liburcu6 (>= 0.10.0) но он не будет установлен
                 Зависит: liblttng-ust-ctl4 (= 2.10.3-1) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет libcurl3 недоступен, но упомянут в списке зависимостей другого
пакета. Это может означать, что пакет отсутствует, устарел или
доступен из источников, не упомянутых в sources.list
Однако следующие пакеты могут его заменить:
  libcurl4

E: Для пакета «libcurl3» не найден кандидат на установку
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет libssl1.0.0 недоступен, но упомянут в списке зависимостей другого
пакета. Это может означать, что пакет отсутствует, устарел или
доступен из источников, не упомянутых в sources.list

E: Для пакета «libssl1.0.0» не найден кандидат на установку
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлен пакет libkrb5-3 самой новой версии (1.17-3).
libkrb5-3 помечен как установленный вручную.
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 kkmserver:armel : Зависит: liblttng-ust0:armel но он не может быть установлен
                   Зависит: libcurl3:armel но он не может быть установлен или
                                   libcurl4:armel но он не может быть установлен
                   Зависит: libssl1.0.0:armel но он не может быть установлен или
                                   libssl1.0.2:armel но он не может быть установлен
                   Зависит: libkrb5-3:armel но он не может быть установлен
                   Зависит: zlib1g:armel но он не может быть установлен
                   Зависит: libc6-dev:armel но он не может быть установлен
                   Зависит: libgdiplus:armel но он не может быть установлен
                   Рекомендует: libicu60:armel но он не может быть установлен или
                                           libicu57:armel но он не может быть установлен или
                                           libicu55:armel но он не может быть установлен или
                                           libicu52:armel но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлен пакет zlib1g самой новой версии (1:1.2.11.dfsg-1).
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 kkmserver:armel : Зависит: liblttng-ust0:armel но он не может быть установлен
                   Зависит: libcurl3:armel но он не может быть установлен или
                                   libcurl4:armel но он не может быть установлен
                   Зависит: libssl1.0.0:armel но он не может быть установлен или
                                   libssl1.0.2:armel но он не может быть установлен
                   Зависит: libkrb5-3:armel но он не может быть установлен
                   Зависит: zlib1g:armel но он не может быть установлен
                   Зависит: libc6-dev:armel но он не может быть установлен
                   Зависит: libgdiplus:armel но он не может быть установлен
                   Рекомендует: libicu60:armel но он не может быть установлен или
                                           libicu57:armel но он не может быть установлен или
                                           libicu55:armel но он не может быть установлен или
                                           libicu52:armel но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлен пакет libc6-dev самой новой версии (2.28-10+rpi1).
libc6-dev помечен как установленный вручную.
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 kkmserver:armel : Зависит: liblttng-ust0:armel но он не может быть установлен
                   Зависит: libcurl3:armel но он не может быть установлен или
                                   libcurl4:armel но он не может быть установлен
                   Зависит: libssl1.0.0:armel но он не может быть установлен или
                                   libssl1.0.2:armel но он не может быть установлен
                   Зависит: libkrb5-3:armel но он не может быть установлен
                   Зависит: zlib1g:armel но он не может быть установлен
                   Зависит: libc6-dev:armel но он не может быть установлен
                   Зависит: libgdiplus:armel но он не может быть установлен
                   Рекомендует: libicu60:armel но он не может быть установлен или
                                           libicu57:armel но он не может быть установлен или
                                           libicu55:armel но он не может быть установлен или
                                           libicu52:armel но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 kkmserver:armel : Зависит: liblttng-ust0:armel но он не может быть установлен
                   Зависит: libcurl3:armel но он не может быть установлен или
                                   libcurl4:armel но он не может быть установлен
                   Зависит: libssl1.0.0:armel но он не может быть установлен или
                                   libssl1.0.2:armel но он не может быть установлен
                   Зависит: libkrb5-3:armel но он не может быть установлен
                   Зависит: zlib1g:armel но он не может быть установлен
                   Зависит: libc6-dev:armel но он не может быть установлен
                   Зависит: libgdiplus:armel но он не может быть установлен
                   Рекомендует: libicu60:armel но он не может быть установлен или
                                           libicu57:armel но он не может быть установлен или
                                           libicu55:armel но он не может быть установлен или
                                           libicu52:armel но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
После всего этого сервер стартует, как разово, так и демоном. Веб интерфейс настроек удаленно открывается, ссылки меню работают. Непонятно только что с основным функционалом при этом, нечем проверить.

MF4
Сообщения: 5
Зарегистрирован: 19 дек 2019, 15:05

Re: Пингвиньи радости

Сообщение MF4 » 23 дек 2019, 15:44

Пробовал на raspberry с последней Ubuntu (armhf и arm64) устанавливать, все равно не ставится, пишет, что архитектура armel не поддерживается. Multiarch не помогает.
Audim, могу по ssh удаленный доступ дать к raspberry для проверки.

Ответить